package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^[a-zàáâäæçèéêëìíîïñòóôœùúûüýÿß](?:[ -][a-z]|['a-zàáâäæçèéêëìíîïñòóôœùúûüýÿß]+)+$`)
var str = `abcdef-abcdef1`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}