import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\))(.+?)(?=\\d|Invalid)";
final String string = "Cloud Innovators Solution (9 months)Social Media Marketing Specialist1/2020 - 10/2020\n"
+ "StoriCamPK (less than a month)Marketing Communications Manager7/2022\n"
+ "Coleman Estate Agents (13 years, 11 months)Director8/2009\n"
+ "Coleman Estate Agents NewYork (13 years, 11 months)Director8/2009\n"
+ "TCS (less than a month)Head of Search Engine Optimization ➤ Brand & Strategy || Go-to-market Strategy || Content Marketer8/2010\n"
+ "Collins Securities Pty Ltd (less than a month) Credit ManagerInvalid date\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}