const regex = /(?<=\))(.+?)(?=\d|Invalid)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\))(.+?)(?=\\d|Invalid)', 'gm')
const str = `Cloud Innovators Solution (9 months)Social Media Marketing Specialist1/2020 - 10/2020
StoriCamPK (less than a month)Marketing Communications Manager7/2022
Coleman Estate Agents (13 years, 11 months)Director8/2009
Coleman Estate Agents NewYork (13 years, 11 months)Director8/2009
TCS (less than a month)Head of Search Engine Optimization ➤ Brand & Strategy || Go-to-market Strategy || Content Marketer8/2010
Collins Securities Pty Ltd (less than a month) Credit ManagerInvalid date
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}