re = /^In the morning.+In the afternoon.+$/m
str = 'In the morning I read the news, then I start my work. In the afternoon I have my lunch.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end