// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)#[\w\d][\w\-]*").unwrap();
let string = "#hashtag some text #hash; #123
#has_htag
#another-hashtag
#this-is-hashtag";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}