package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^|,)ACTIVE-(\d+)`)
var str = `ACTIVE-6,CATEGORY-ACTIVE-8,CATEGORY-ACTIVE-4,ACTIVE-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}