re = /(^|,)ACTIVE-(\d+)/
str = 'ACTIVE-6,CATEGORY-ACTIVE-8,CATEGORY-ACTIVE-4,ACTIVE-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end