package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^arn:(?P<Partition>[^:\n]*):(?P<Service>[^:\n]*):(?P<Region>[^:\n]*):(?P<AccountID>[^:\n]*):(?P<Ignore>(?P<ResourceType>[^:\/\n]*)[:\/])?(?P<Resource>.*)$`)
var str = `arn:aws:iam::509414592636:user/lf-developer"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}