re = /^arn:(?P<Partition>[^:\n]*):(?P<Service>[^:\n]*):(?P<Region>[^:\n]*):(?P<AccountID>[^:\n]*):(?P<Ignore>(?P<ResourceType>[^:\/\n]*)[:\/])?(?P<Resource>.*)$/m
str = 'arn:aws:iam::509414592636:user/lf-developer"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end