const regex = /(?(DEFINE) (?<taboo> \h* (?<!\pL) (?:we|you) (?!\pL) \h*) ) (?: (?&taboo) )* ( (?: (?! (?&taboo) ) \N)* ) (?: (?&taboo) )* \K/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE) (?<taboo> \\h* (?<!\\pL) (?:we|you) (?!\\pL) \\h*) ) (?: (?&taboo) )* ( (?: (?! (?&taboo) ) \\N)* ) (?: (?&taboo) )* \\K', 'ig')
const str = `We Remember you we advised you to clear your cache and cookies, now we are not guilty: you are.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}