$re = '/(?(DEFINE) (?<taboo> \h* (?<!\pL) (?:we|you) (?!\pL) \h*) ) (?: (?&taboo) )* ( (?: (?! (?&taboo) ) \N)* ) (?: (?&taboo) )* \K/ix';
$str = 'We Remember you we advised you to clear your cache and cookies, now we are not guilty: you are.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);