using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^<](?=[^<]*((?=(\1?))\2<BckSp>)))+\1";
string input = @"Helllo<BckSp><BckSp>o world";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}