re = /(?:[^<](?=[^<]*((?=(\1?))\2<BckSp>)))+\1/
str = 'Helllo<BckSp><BckSp>o world'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end