# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((([A-Za-z]{3,9}:(?:\\/\\/)?)(?:[-;:&=\+\$,\w]+@)?[A-Za-z0-9.-]+|(?:www.|[-;:&=\+\$,\w]+@)[A-Za-z0-9.-]+)((?:\\/[\+~%\\/.\w-_]*)?\??(?:[-\+=&;%@.\w_]*)#?(?:[.\!\\/\\w]*))?)//ig;t' <<< "Good Day,I would like to $1000 (for example remove these parenthesis) $test $ asdf [and remove these brackets] inquire the price of the 3D product name here. Currently we have the other product name here which I believe has an accuracy of about 0.0005 199 200. http://www.example.com this is a test"