package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b([1-9])\g{1}0\b`)
var str = `110
220
550
000
123
456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}