$re = '/\b([1-9])\g{1}0\b/';
$str = '110
220
550
000
123
456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);