using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^()";
string input = @"недревесное сырье:,Актинидия (15) 0,7 м,1,5 кг/га
недревесное сырье:,Калина (10) 1,2 м,0,1 кг/га
недревесное сырье:,Актинидия (15) 0,7 м,3,5 кг/га,Лимонник (15) 3,5 м,3,5 кг/га,
недревесное сырье:,Лимонник (10) 2,0 м,1,0 кг/га
недревесное сырье:,ЭЛЕУТЕРОКОКК (5) 2,0 м,0,5 кг/га
недревесное сырье:,Лимонник (10) 2,0 м,0,2 кг/га,Виноград (10) 2,0 м,0,1 кг/га
недревесное сырье:кедровый орех,аралия (5) 2,4 м,1,8 кг/га
недревесное сырье:орехи,Лещина (10) 5,0 м,20,0 кг/га
недревесное сырье:,Актинидия (10) 0,4 м,3,5 кг/га,Виноград (15) 0,3 м,0,2 кг/га
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}