import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{6,284}$)[^\\W_](?:[+\\w.-]*[^\\W_])?@[^\\W_](?:\\[[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.|(?:[\\w-]+\\.)+)(?:[a-zA-Z]{2,13}|[0-9]{1,3})\\]?$";
final String string = ".abc@ornekeposta.com\n"
+ "_abc@ornekeposta.com\n"
+ "9abc.@ornekeposta.com\n"
+ "!@ornekeposta.com\n"
+ "a!@ornekeposta.com\n"
+ "ö@ö@.ö\n"
+ "#4+^%+@göl.çöz\n"
+ "!'^+%&&/)=?:_@^+%+^&%(.+%^+%%+/&%&.com\n"
+ "a_@a.aa\n"
+ "21322534@435345345.4353.4543\n"
+ "a@aa.aa\n"
+ "1@12.co\n"
+ "a.1@555555.com\n"
+ "a@ornekeposta.com\n"
+ "9abc@ornekeposta.com\n"
+ "abc@ornekeposta.org.tr\n"
+ "m@it.ai.tr.cz.ru.dart\n"
+ "name@surname.aero\n"
+ "AAAA@AAA.AA\n"
+ "deneme+tag@deneme.com\n"
+ "very-important@person.international\n"
+ "istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul.istanbul.istanbul.istanbul+istanbul@4istanbul.istanbul-istanbul-istanbul-istanbul-istanbul.istanbul.ista.istanbul\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}