$re = '/^(?=.{6,284}$)[^\W_](?:[+\w.-]*[^\W_])?@[^\W_](?:\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.|(?:[\w-]+\.)+)(?:[a-zA-Z]{2,13}|[0-9]{1,3})\]?$/m';
$str = '.abc@ornekeposta.com
_abc@ornekeposta.com
9abc.@ornekeposta.com
!@ornekeposta.com
a!@ornekeposta.com
ö@ö@.ö
#4+^%+@göl.çöz
!\'^+%&&/)=?:_@^+%+^&%(.+%^+%%+/&%&.com
a_@a.aa
21322534@435345345.4353.4543
a@aa.aa
1@12.co
a.1@555555.com
a@ornekeposta.com
9abc@ornekeposta.com
abc@ornekeposta.org.tr
m@it.ai.tr.cz.ru.dart
name@surname.aero
AAAA@AAA.AA
deneme+tag@deneme.com
very-important@person.international
istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul-istanbul.istanbul.istanbul.istanbul+istanbul@4istanbul.istanbul-istanbul-istanbul-istanbul-istanbul.istanbul.ista.istanbul
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);