import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^rgb[(](?:\\s*0*(?:\\d\\d?(?:\\.\\d+)?(?:\\s*%)?|\\.\\d+\\s*%|100(?:\\.0*)?\\s*%|(?:1\\d\\d|2[0-4]\\d|25[0-5])(?:\\.\\d+)?)\\s*(?:,(?![)])|(?=[)]))){3}[)]$";
final String string = "#0F0F0F\n"
+ "#123\n"
+ "#1234\n"
+ "#ABC456\n"
+ "#1234567\n"
+ "rgb(1,2,3)\n"
+ "rgb(1,2,)\n"
+ "rgb(112233)\n"
+ "rgb(255,249,199)\n"
+ "rgb(256,249,199)\n"
+ "rgb(255,249,199,)\n"
+ "rgb( 100%, 199, 50%)\n"
+ "rgb( 100%, 199%, 50%)\n"
+ "rgb(1,2,3%,.5)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}