# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^rgb[(](?:\s*0*(?:\d\d?(?:\.\d+)?(?:\s*%)?|\.\d+\s*%|100(?:\.0*)?\s*%|(?:1\d\d|2[0-4]\d|25[0-5])(?:\.\d+)?)\s*(?:,(?![)])|(?=[)]))){3}[)]$"
test_str = ("#0F0F0F\n"
"#123\n"
"#1234\n"
"#ABC456\n"
"#1234567\n"
"rgb(1,2,3)\n"
"rgb(1,2,)\n"
"rgb(112233)\n"
"rgb(255,249,199)\n"
"rgb(256,249,199)\n"
"rgb(255,249,199,)\n"
"rgb( 100%, 199, 50%)\n"
"rgb( 100%, 199%, 50%)\n"
"rgb(1,2,3%,.5)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.