using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^1\-(2\d[1-9])|([3-8]\d{2})|(9[0-8]\d)$";
string input = @"1-990";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}