$re = '/^1\-(2\d[1-9])|([3-8]\d{2})|(9[0-8]\d)$/';
$str = '1-990';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);