import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+|00)?33(6|7)([0-9]{8})$";
final String string = "0986423268\n"
+ "01436464654654654\n"
+ "0754554565\n"
+ "0678866556\n"
+ "6078866556\n"
+ "336845269846685\n"
+ "33684526985\n"
+ "33784526985\n\n"
+ "0033784526985\n"
+ "00337845269855\n"
+ "003378452698\n\n"
+ "+33784526845\n"
+ "+33584526984\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}