// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\+|00)?33(6|7)([0-9]{8})$").unwrap();
let string = "0986423268
01436464654654654
0754554565
0678866556
6078866556
336845269846685
33684526985
33784526985
0033784526985
00337845269855
003378452698
+33784526845
+33584526984
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}