const regex = /"[^"\r\n]*"|'[^'\r\n]*'|[^,\r\n]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"[^"\\r\\n]*"|\'[^\'\\r\\n]*\'|[^,\\r\\n]*', 'gm')
const str = `7,"U.S. Representative, Dist I - N",7,"OF",,367,20,"GRIFFIN, Calvin (G)",1,"",314,45,193,552`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}