$re = '/"[^"\r\n]*"|\'[^\'\r\n]*\'|[^,\r\n]*/m';
$str = '7,"U.S. Representative, Dist I - N",7,"OF",,367,20,"GRIFFIN, Calvin (G)",1,"",314,45,193,552';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);