package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Z]\d{12}[A-Z]`)
var str = `D160289784495A`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}