$re = '/[A-Z]\d{12}[A-Z]/';
$str = 'D160289784495A';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);