$re = '/([^,]+)(,[ ]*\1)+/m';
$str = 'VA - HRD 1, VA - HRD 1, VA - NOVA 1, VA - NOVA 1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);