re = /([^,]+)(,[ ]*\1)+/m
str = 'VA - HRD 1, VA - HRD 1, VA - NOVA 1, VA - NOVA 1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end