#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<li>(Pg_.*)<\/li>"
Local $sString = "<ul>" & @CRLF & _
" <li><a href="#symbols">Symbol report</a></li>" & @CRLF & _
"<ul>" & @CRLF & _
" <li><a href="#symbolsConsistency">Consistency</a></li>" & @CRLF & _
" <li><a href="#symbolCharacteristics">Symbol characteristics</a></li>" & @CRLF & _
" <li><a href="#basicSymbols">Display of basic symbols</a></li>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <ul>" & @CRLF & _
" <li>Pg_1_qds_Bin_Indicator_2</li>" & @CRLF & _
" <ul>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.descriptionalignment] = (Right)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.descriptiontextcolor] = (Color {0, 0, 0, 255})</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.isdescriptiondisplayed] = (true)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.descriptionfontfamily] = (Arial)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.descriptionfontsize] = (11 pt)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.descriptionfontstyle] = (Normal)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.descriptionfontposition] = (LEFT)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.descriptiontext] = (v1)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.backgroundcolor] = (Color {238, 238, 238, 255})</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.digitnumber] = (8)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.widgetfont] = (FONT1)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.shortname] = (Pg_1_qds_Bin_Indicator_2)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.precision] = (2)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.widgetuserfontfamily] = (Arial)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.widgetuserfontsize] = (11 pt)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.widgetuserfontstyle] = (NORMAL)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.dynamicbackgroundcolor] = (Color {238, 238, 238, 255})</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.longname] = (Pg_1_qds_Bin_Indicator_2_v1)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.heith] = (32)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.weigth] = (50)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.poxX] = (352)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.poxY] = (116)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.valuealignment] = (Left)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.value_0] = (Off)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.value_1] = (On)</li>" & @CRLF & _
" </ul>" & @CRLF & _
" <li>Pg_1_qds_Bin_Indicator_3</li>" & @CRLF & _
" <ul>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.descriptionalignment] = (Right)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.descriptiontextcolor] = (Color {0, 0, 0, 255})</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.isdescriptiondisplayed] = (true)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.descriptionfontfamily] = (Arial)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.descriptionfontsize] = (11 pt)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.descriptionfontstyle] = (Normal)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.descriptionfontposition] = (LEFT)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.descriptiontext] = (v1)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.backgroundcolor] = (Color {238, 238, 238, 255})</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.digitnumber] = (8)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.widgetfont] = (FONT1)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.shortname] = (Pg_1_qds_Bin_Indicator_3)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.precision] = (2)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.widgetuserfontfamily] = (Arial)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.widgetuserfontsize] = (11 pt)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.widgetuserfontstyle] = (NORMAL)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.dynamicbackgroundcolor] = (Color {238, 238, 238, 255})</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.longname] = (Pg_1_qds_Bin_Indicator_3_v1)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.heith] = (32)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.weigth] = (50)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.poxX] = (446)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.poxY] = (187)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.valuealignment] = (Left)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.value_0] = (Off)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.logicIndicator.value_1] = (On)</li>" & @CRLF & _
" </ul>" & @CRLF & _
" </ul>" & @CRLF & _
" <p><em>Analog indicator :</em></p>" & @CRLF & _
" <ul>" & @CRLF & _
" <li>Pg_1_qds_Ana_Indicator_1</li>" & @CRLF & _
" <ul>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.descriptionalignment] = (Right)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.descriptiontextcolor] = (Color {0, 0, 0, 255})</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.isdescriptiondisplayed] = (true)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.descriptionfontfamily] = (Arial)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.descriptionfontsize] = (11 pt)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.descriptionfontstyle] = (Normal)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.descriptionfontposition] = (LEFT)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.descriptiontext] = (v0)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.backgroundcolor] = (Color {238, 238, 238, 255})</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.digitnumber] = (8)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.widgetfont] = (FONT1)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.shortname] = (Pg_1_qds_Ana_Indicator_1)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.precision] = (2)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.widgetuserfontfamily] = (Arial)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.widgetuserfontsize] = (11 pt)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.widgetuserfontstyle] = (NORMAL)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.dynamicbackgroundcolor] = (Color {238, 238, 238, 255})</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.longname] = (Pg_1_qds_Ana_Indicator_1_v0)</li>" & @CRLF & _
" <li>[QDSConsistency.report.field.analogIndicator.heith] = (32)</li>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")