// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<li>(Pg_.*)<\/li>").unwrap();
let string = "<ul>
<li><a href=\"#symbols\">Symbol report</a></li>
<ul>
<li><a href=\"#symbolsConsistency\">Consistency</a></li>
<li><a href=\"#symbolCharacteristics\">Symbol characteristics</a></li>
<li><a href=\"#basicSymbols\">Display of basic symbols</a></li>
<ul>
<li>Pg_1_qds_Bin_Indicator_2</li>
<ul>
<li>[QDSConsistency.report.field.logicIndicator.descriptionalignment] = (Right)</li>
<li>[QDSConsistency.report.field.logicIndicator.descriptiontextcolor] = (Color {0, 0, 0, 255})</li>
<li>[QDSConsistency.report.field.logicIndicator.isdescriptiondisplayed] = (true)</li>
<li>[QDSConsistency.report.field.logicIndicator.descriptionfontfamily] = (Arial)</li>
<li>[QDSConsistency.report.field.logicIndicator.descriptionfontsize] = (11 pt)</li>
<li>[QDSConsistency.report.field.logicIndicator.descriptionfontstyle] = (Normal)</li>
<li>[QDSConsistency.report.field.logicIndicator.descriptionfontposition] = (LEFT)</li>
<li>[QDSConsistency.report.field.analogIndicator.descriptiontext] = (v1)</li>
<li>[QDSConsistency.report.field.logicIndicator.backgroundcolor] = (Color {238, 238, 238, 255})</li>
<li>[QDSConsistency.report.field.logicIndicator.digitnumber] = (8)</li>
<li>[QDSConsistency.report.field.logicIndicator.widgetfont] = (FONT1)</li>
<li>[QDSConsistency.report.field.logicIndicator.shortname] = (Pg_1_qds_Bin_Indicator_2)</li>
<li>[QDSConsistency.report.field.logicIndicator.precision] = (2)</li>
<li>[QDSConsistency.report.field.logicIndicator.widgetuserfontfamily] = (Arial)</li>
<li>[QDSConsistency.report.field.logicIndicator.widgetuserfontsize] = (11 pt)</li>
<li>[QDSConsistency.report.field.analogIndicator.widgetuserfontstyle] = (NORMAL)</li>
<li>[QDSConsistency.report.field.analogIndicator.dynamicbackgroundcolor] = (Color {238, 238, 238, 255})</li>
<li>[QDSConsistency.report.field.analogIndicator.longname] = (Pg_1_qds_Bin_Indicator_2_v1)</li>
<li>[QDSConsistency.report.field.logicIndicator.heith] = (32)</li>
<li>[QDSConsistency.report.field.logicIndicator.weigth] = (50)</li>
<li>[QDSConsistency.report.field.logicIndicator.poxX] = (352)</li>
<li>[QDSConsistency.report.field.logicIndicator.poxY] = (116)</li>
<li>[QDSConsistency.report.field.logicIndicator.valuealignment] = (Left)</li>
<li>[QDSConsistency.report.field.logicIndicator.value_0] = (Off)</li>
<li>[QDSConsistency.report.field.logicIndicator.value_1] = (On)</li>
</ul>
<li>Pg_1_qds_Bin_Indicator_3</li>
<ul>
<li>[QDSConsistency.report.field.logicIndicator.descriptionalignment] = (Right)</li>
<li>[QDSConsistency.report.field.logicIndicator.descriptiontextcolor] = (Color {0, 0, 0, 255})</li>
<li>[QDSConsistency.report.field.logicIndicator.isdescriptiondisplayed] = (true)</li>
<li>[QDSConsistency.report.field.logicIndicator.descriptionfontfamily] = (Arial)</li>
<li>[QDSConsistency.report.field.logicIndicator.descriptionfontsize] = (11 pt)</li>
<li>[QDSConsistency.report.field.logicIndicator.descriptionfontstyle] = (Normal)</li>
<li>[QDSConsistency.report.field.logicIndicator.descriptionfontposition] = (LEFT)</li>
<li>[QDSConsistency.report.field.analogIndicator.descriptiontext] = (v1)</li>
<li>[QDSConsistency.report.field.logicIndicator.backgroundcolor] = (Color {238, 238, 238, 255})</li>
<li>[QDSConsistency.report.field.logicIndicator.digitnumber] = (8)</li>
<li>[QDSConsistency.report.field.logicIndicator.widgetfont] = (FONT1)</li>
<li>[QDSConsistency.report.field.logicIndicator.shortname] = (Pg_1_qds_Bin_Indicator_3)</li>
<li>[QDSConsistency.report.field.logicIndicator.precision] = (2)</li>
<li>[QDSConsistency.report.field.logicIndicator.widgetuserfontfamily] = (Arial)</li>
<li>[QDSConsistency.report.field.logicIndicator.widgetuserfontsize] = (11 pt)</li>
<li>[QDSConsistency.report.field.analogIndicator.widgetuserfontstyle] = (NORMAL)</li>
<li>[QDSConsistency.report.field.analogIndicator.dynamicbackgroundcolor] = (Color {238, 238, 238, 255})</li>
<li>[QDSConsistency.report.field.analogIndicator.longname] = (Pg_1_qds_Bin_Indicator_3_v1)</li>
<li>[QDSConsistency.report.field.logicIndicator.heith] = (32)</li>
<li>[QDSConsistency.report.field.logicIndicator.weigth] = (50)</li>
<li>[QDSConsistency.report.field.logicIndicator.poxX] = (446)</li>
<li>[QDSConsistency.report.field.logicIndicator.poxY] = (187)</li>
<li>[QDSConsistency.report.field.logicIndicator.valuealignment] = (Left)</li>
<li>[QDSConsistency.report.field.logicIndicator.value_0] = (Off)</li>
<li>[QDSConsistency.report.field.logicIndicator.value_1] = (On)</li>
</ul>
</ul>
<p><em>Analog indicator :</em></p>
<ul>
<li>Pg_1_qds_Ana_Indicator_1</li>
<ul>
<li>[QDSConsistency.report.field.analogIndicator.descriptionalignment] = (Right)</li>
<li>[QDSConsistency.report.field.analogIndicator.descriptiontextcolor] = (Color {0, 0, 0, 255})</li>
<li>[QDSConsistency.report.field.analogIndicator.isdescriptiondisplayed] = (true)</li>
<li>[QDSConsistency.report.field.analogIndicator.descriptionfontfamily] = (Arial)</li>
<li>[QDSConsistency.report.field.analogIndicator.descriptionfontsize] = (11 pt)</li>
<li>[QDSConsistency.report.field.analogIndicator.descriptionfontstyle] = (Normal)</li>
<li>[QDSConsistency.report.field.analogIndicator.descriptionfontposition] = (LEFT)</li>
<li>[QDSConsistency.report.field.analogIndicator.descriptiontext] = (v0)</li>
<li>[QDSConsistency.report.field.analogIndicator.backgroundcolor] = (Color {238, 238, 238, 255})</li>
<li>[QDSConsistency.report.field.analogIndicator.digitnumber] = (8)</li>
<li>[QDSConsistency.report.field.analogIndicator.widgetfont] = (FONT1)</li>
<li>[QDSConsistency.report.field.analogIndicator.shortname] = (Pg_1_qds_Ana_Indicator_1)</li>
<li>[QDSConsistency.report.field.analogIndicator.precision] = (2)</li>
<li>[QDSConsistency.report.field.analogIndicator.widgetuserfontfamily] = (Arial)</li>
<li>[QDSConsistency.report.field.analogIndicator.widgetuserfontsize] = (11 pt)</li>
<li>[QDSConsistency.report.field.analogIndicator.widgetuserfontstyle] = (NORMAL)</li>
<li>[QDSConsistency.report.field.analogIndicator.dynamicbackgroundcolor] = (Color {238, 238, 238, 255})</li>
<li>[QDSConsistency.report.field.analogIndicator.longname] = (Pg_1_qds_Ana_Indicator_1_v0)</li>
<li>[QDSConsistency.report.field.analogIndicator.heith] = (32)</li>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}