$re = '/^(.+) (\d+\w*), (.+)$/m';
$str = 'streetA 15, New York
street number 2 35, California
streetB 36B, Texas';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);