re = /^(.+) (\d+\w*), (.+)$/m
str = 'streetA 15, New York
street number 2 35, California
streetB 36B, Texas'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end