$re = '/^(?!.*\b(?:badword|test)\b).*$/m';
$str = 'ghjghj badword test ghjghj
one two
abadwords
three';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);