re = /^(?!.*\b(?:badword|test)\b).*$/m
str = 'ghjghj badword test ghjghj
one two
abadwords
three'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end