#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w+\s[\d-]+\s[\d:,]+\s(.*(?<!authentication\s)failed)"
Local $sString = "INFO 2013-09-17 12:13:44,487 authentication failed" & @CRLF & _
"INFO 2013-09-17 12:13:44,487 matching failed"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")