$re = '/\w+\s[\d-]+\s[\d:,]+\s(.*(?<!authentication\s)failed)/';
$str = 'INFO 2013-09-17 12:13:44,487 authentication failed
INFO 2013-09-17 12:13:44,487 matching failed';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);