$re = '/\d+(-\d+)+/m';
$str = '10-20-30
100-200-300-400
10-20-30-40-50 ffff
10-20-30-40-50
10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);