re = /\d+(-\d+)+/m
str = '10-20-30
100-200-300-400
10-20-30-40-50 ffff
10-20-30-40-50
10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end