re = /@\(
(?:
\s*
(?:
"[^"\\]*(?:\\.[^"\\]*)*"
|
[\w-]+(?:="?[^"\\]*(?:\\.[^"\\]*)*"?)?
)
)+
\s*
\)/x
str = '@("hello, world" bold italic font-size="15")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end