package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z]{1,4}\d*$`)
var str = `crow1111111111
crowe111111111
cro111111111
111111crow`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}