$re = '/^[A-Za-z]{1,4}\d*$/m';
$str = 'crow1111111111
crowe111111111
cro111111111
111111crow';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);