const regex = /if\s*\((.+?)\)\s*{(.*?)}\s*?(else\s*?if\s*?\((.+?)\)\s*?{.*?})?\s*?(else\s*?{(.*?)})?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('if\\s*\\((.+?)\\)\\s*{(.*?)}\\s*?(else\\s*?if\\s*?\\((.+?)\\)\\s*?{.*?})?\\s*?(else\\s*?{(.*?)})?', '')
const str = `if(condition){result }else if(condition){}else{}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}