using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\<((?:(?!\>).)+)";
string input = @"<https://api.github.com/repositories/2164979/issues?page=2>; rel=\""next\"", <https://api.github.com/repositories/2164979/issues?page=6>; rel=\""last\""";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}