re = /\<((?:(?!\>).)+)/im
str = '<https://api.github.com/repositories/2164979/issues?page=2>; rel=\\"next\\", <https://api.github.com/repositories/2164979/issues?page=6>; rel=\\"last\\"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end