import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)insuficiencia[\\s]{0,3}hep[Ááa]tica|fall[ao](.){0,9}funci[Óóo]n[\\s]{0,3}hep[Ááa]tica|descompensaci[Óóo][\\s]{0,3}hep[Ááa]tica|descompensaci[Óóo]n[\\s]{0,3}hep[Ááa]tica|fall[oa][\\s]{0,3}hep[Ááa]tic[ao]|disfunci[Óóo]n[\\s]{0,3}hep[Ááa]tica|deterioro(.){0,8}funci[Óóo]n[\\s]hep[Ááa]tica";
final String string = "insuficiencia hepática\n"
+ "falla de la función hepática\n"
+ "fallo de funcion hepatica\n"
+ "fallo de funcion hepÁtica\n"
+ "descompensación hepática\n"
+ "falla hepática\n"
+ "fallo hepatico\n"
+ "disfuncion hepatica\n"
+ "deterioro de la funcion hepatica\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}