using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=-).*?(?=\""\n)";
string input = @"android:versionName=""0.7-191027""
android:sharedUserId=""android.uid.system"">
encoding=""utf-8""?>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}