$re = '/(?<=-).*?(?=\"\n)/';
$str = 'android:versionName="0.7-191027"
android:sharedUserId="android.uid.system">
encoding="utf-8"?>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);